Author Topic: QTP behaviour is not correct whilst added and selecting a row in the grid flex  (Read 1256 times)

Offline sonia saini

  • Newbie
  • *
  • Posts: 3
  • I\'m a software tester.
I'm having a very different issue either my function or QTP. When i'm adding a new row via my function,row is added successful,when i do debug it is selecting the second row but clicked on the first one row.

Can you guys please help me out on this where i'm doing mistake?
 
I've attached the function,Screen shot and .xls file.
Please glance on it and let me know.

I would appreciate quick response.

Error will be in PAX Cat AED tab in the xls.
« Last Edit: September 10, 2009, 07:53:48 am by ssaini »

Offline Tarun Lalwani

  • Administrator
  • Hero Member
  • *****
  • Posts: 3025
    • KnowledgeInbox
I looked at your excel but could not understand what your issue means exactly? can you provide more details
Regards,
Tarun
KnowledgeInbox Administrator

KnowledgeInbox" style="border:0

Offline sonia saini

  • Newbie
  • *
  • Posts: 3
  • I\'m a software tester.
Thank you so much tarun to give  response.

Tarun - If you would have gone through by xls and function  then you could have found an error in red color. When i run my function in debug mode  then QTP selects the previously added row not that one which has been newly added. In a very simple word problem is about the selection of row.

Expected Result should be - QTP should select the newly added row not previous one. In normal mode everything works fine.



Offline Tarun Lalwani

  • Administrator
  • Hero Member
  • *****
  • Posts: 3025
    • KnowledgeInbox
The only thing i can think of is that when you debug because focus is on QTP and the code to select the latest row does not work properly
Regards,
Tarun
KnowledgeInbox Administrator

KnowledgeInbox" style="border:0